CVE-2022-3965

Name
CVE-2022-3965
Description
A vulnerability classified as problematic was found in ffmpeg. This vulnerability affects the function smc_encode_stream of the file libavcodec/smcenc.c of the component QuickTime Graphics Video Encoder. The manipulation of the argument y_size leads to out-of-bounds read. The attack can be initiated remotely. The name of the patch is 13c13109759090b7f7182480d075e13b36ed8edd. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-213544.
NVD Severity
unknown
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
N/A https://git.ffmpeg.org/gitweb/ffmpeg.git/commit/13c13109759090b7f7182480d075e13b36ed8edd
N/A https://vuldb.com/?id.213544
cna@vuldb.com https://security.gentoo.org/glsa/202312-14

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:ffmpeg:ffmpeg:*:*:*:*:*:*:*:* ffmpeg >= None < 2022-11-12
cpe:2.3:a:ffmpeg:ffmpeg:*:*:*:*:*:*:*:* ffmpeg >= 5.0 < 6.0
cpe:2.3:a:ffmpeg:ffmpeg:*:*:*:*:*:*:*:* ffmpeg >= 5.0 < 5.0.3
cpe:2.3:a:ffmpeg:ffmpeg:*:*:*:*:*:*:*:* ffmpeg >= 5.1 < 5.1.3

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
ffmpeg 3.16-community 5.0.1-r1 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
ffmpeg 3.17-community 5.1.3-r0 Natanael Copa <ncopa@alpinelinux.org> fixed
ffmpeg 3.18-community 6.0.1-r0 Natanael Copa <ncopa@alpinelinux.org> fixed
ffmpeg 3.19-community 6.1.1-r0 Natanael Copa <ncopa@alpinelinux.org> fixed
ffmpeg edge-community 6.1.1-r3 Natanael Copa <ncopa@alpinelinux.org> fixed