CVE-2022-36922

Name
CVE-2022-36922
Description
Jenkins Lucene-Search Plugin 370.v62a5f618cd3a and earlier does not escape the search query parameter displayed on the 'search' result page, resulting in a reflected cross-site scripting (XSS) vulnerability.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
CONFIRM https://www.jenkins.io/security/advisory/2022-07-27/#SECURITY-2812
MLIST http://www.openwall.com/lists/oss-security/2022/07/27/1

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:lucene-search:*:*:*:*:*:jenkins:*:* jenkins >= None <= 370.v62a5f618cd3a

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins 3.16-community 2.346.2-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins edge-community 2.361.2-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.17-community 2.361.2-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable