CVE-2022-36889

Name
CVE-2022-36889
Description
Jenkins Deployer Framework Plugin 85.v1d1888e8c021 and earlier does not restrict the application path of the applications when configuring a deployment, allowing attackers with Item/Configure permission to upload arbitrary files from the Jenkins controller file system to the selected service.
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
CONFIRM https://www.jenkins.io/security/advisory/2022-07-27/#SECURITY-2764
MLIST http://www.openwall.com/lists/oss-security/2022/07/27/1

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:deployer_framework:*:*:*:*:*:jenkins:*:* jenkins >= None <= 85.v1d1888e8c021

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins 3.16-community 2.346.2-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins edge-community 2.361.2-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.17-community 2.361.2-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable