CVE-2022-3647

Name
CVE-2022-3647
Description
** DISPUTED ** A vulnerability, which was classified as problematic, was found in Redis. Affected is the function sigsegvHandler of the file debug.c of the component Crash Report. The manipulation leads to denial of service. The real existence of this vulnerability is still doubted at the moment. The name of the patch is 0bf90d944313919eb8e63d3588bf63a367f020a3. It is recommended to apply a patch to fix this issue. VDB-211962 is the identifier assigned to this vulnerability. NOTE: The vendor claims that this is not a DoS because it applies to the crash logging mechanism which is triggered after a crash has occurred.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
N/A https://github.com/redis/redis/commit/0bf90d944313919eb8e63d3588bf63a367f020a3
N/A https://vuldb.com/?id.211962

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:redis:redis:*:*:*:*:*:*:*:* redis >= None < 2022-09-29

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
redis edge-main 7.0.5-r0 TBK <alpine@jjtc.eu> possibly vulnerable
redis 3.16-main 7.0.5-r0 TBK <alpine@jjtc.eu> possibly vulnerable
redis 3.15-main 6.2.7-r0 TBK <alpine@jjtc.eu> possibly vulnerable
redis 3.14-main 6.2.7-r0 TBK <alpine@jjtc.eu> possibly vulnerable
redis 3.13-main 6.0.16-r0 TBK <alpine@jjtc.eu> possibly vulnerable
redis 3.17-main 7.0.5-r0 TBK <alpine@jjtc.eu> possibly vulnerable