CVE-2022-35919

Name
CVE-2022-35919
Description
MinIO is a High Performance Object Storage released under GNU Affero General Public License v3.0. In affected versions all 'admin' users authorized for `admin:ServerUpdate` can selectively trigger an error that in response, returns the content of the path requested. Any normal OS system would allow access to contents at any arbitrary paths that are readable by MinIO process. Users are advised to upgrade. Users unable to upgrade may disable ServerUpdate API by denying the `admin:ServerUpdate` action for your admin users via IAM policies.
NVD Severity
low
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://github.com/minio/minio/commit/bc72e4226e669d98c8e0f3eccc9297be9251c692
MISC https://github.com/minio/minio/pull/15429
CONFIRM https://github.com/minio/minio/security/advisories/GHSA-gr9v-6pcm-rqvg

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:minio:minio:*:*:*:*:*:*:*:* minio >= None < 2022-07-29t19-40-48z

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
minio edge-community 0.20221029.062133-r1 Drew DeVault <sir@cmpwn.com> possibly vulnerable
minio 3.17-community 0.20221029.062133-r1 Drew DeVault <sir@cmpwn.com> possibly vulnerable