CVE-2022-3437

Name
CVE-2022-3437
Description
A heap-based buffer overflow vulnerability was found in Samba within the GSSAPI unwrap_des() and unwrap_des3() routines of Heimdal. The DES and Triple-DES decryption routines in the Heimdal GSSAPI library allow a length-limited write buffer overflow on malloc() allocated memory when presented with a maliciously small packet. This flaw allows a remote user to send specially crafted malicious data to the application, possibly resulting in a denial of service (DoS) attack.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://www.samba.org/samba/security/CVE-2022-3437.html
MISC https://bugzilla.redhat.com/show_bug.cgi?id=2137774
MISC https://access.redhat.com/security/cve/CVE-2022-3437

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:samba:samba:*:*:*:*:*:*:*:* samba >= 4.17.0 < 4.17.2
cpe:2.3:a:samba:samba:*:*:*:*:*:*:*:* samba >= 4.16.0 < 4.16.6
cpe:2.3:a:samba:samba:*:*:*:*:*:*:*:* samba >= 4.0.0 < 4.15.11

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
heimdal 3.14-main 7.7.1-r0 Leonardo Arena <rnalrd@alpinelinux.org> fixed
samba 3.16-main 4.15.7-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
samba 3.14-main 4.14.14-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable