CVE-2022-34191

Name
CVE-2022-34191
Description
Jenkins NS-ND Integration Performance Publisher Plugin 4.8.0.77 and earlier does not escape the name of NetStorm Test parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
CONFIRM https://www.jenkins.io/security/advisory/2022-06-22/#SECURITY-2784

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:ns-nd_integration_performance_publisher:*:*:*:*:*:jenkins:*:* jenkins >= None <= 4.8.0.77

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins edge-community 2.346.2-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.16-community 2.346.2-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable