CVE-2022-31624

Name
CVE-2022-31624
Description
MariaDB Server before 10.7 is vulnerable to Denial of Service. While executing the plugin/server_audit/server_audit.c method log_statement_ex, the held lock lock_bigbuffer is not released correctly, which allows local users to trigger a denial of service due to the deadlock.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://jira.mariadb.org/browse/MDEV-26556?filter=-2
MISC https://github.com/MariaDB/server/commit/d627d00b13ab2f2c0954ea7b77202470cb102944

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:* mariadb >= None < 10.7.0
cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:* mariadb >= None < 10.2.41
cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:* mariadb >= 10.3.0 < 10.3.32
cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:* mariadb >= 10.4.0 < 10.4.22
cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:* mariadb >= 10.5.0 < 10.5.13
cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:* mariadb >= 10.6.0 < 10.6.5

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
mariadb edge-main 10.6.8-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
mariadb 3.16-main 10.6.8-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
mariadb 3.15-main 10.6.8-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
mariadb 3.14-main 10.5.16-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
mariadb 3.13-main 10.5.16-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable