CVE-2022-31622

Name
CVE-2022-31622
Description
MariaDB Server before 10.7 is vulnerable to Denial of Service. In extra/mariabackup/ds_compress.cc, when an error occurs (pthread_create returns a nonzero value) while executing the method create_worker_threads, the held lock is not released correctly, which allows local users to trigger a denial of service due to the deadlock.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://jira.mariadb.org/browse/MDEV-26561?filter=-2
MISC https://github.com/MariaDB/server/commit/e1eb39a446c30b8459c39fd7f2ee1c55a36e97d2

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:* mariadb >= None < 10.7.0
cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:* mariadb >= 10.3.0 < 10.3.33
cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:* mariadb >= 10.4.0 < 10.4.23
cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:* mariadb >= 10.5.0 < 10.5.14
cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:* mariadb >= 10.7.0 < 10.7.2
cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:* mariadb >= 10.6.0 < 10.6.6
cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:* mariadb >= None < 10.2.42

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
mariadb edge-main 10.6.8-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
mariadb 3.16-main 10.6.8-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
mariadb 3.15-main 10.6.8-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
mariadb 3.14-main 10.5.16-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
mariadb 3.13-main 10.5.16-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable