CVE-2022-31030

Name
CVE-2022-31030
Description
containerd is an open source container runtime. A bug was found in the containerd's CRI implementation where programs inside a container can cause the containerd daemon to consume memory without bound during invocation of the `ExecSync` API. This can cause containerd to consume all available memory on the computer, denying service to other legitimate workloads. Kubernetes and crictl can both be configured to use containerd's CRI implementation; `ExecSync` may be used when running probes or when executing processes via an "exec" facility. This bug has been fixed in containerd 1.6.6 and 1.5.13. Users should update to these versions to resolve the issue. Users unable to upgrade should ensure that only trusted images and commands are used.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
CONFIRM https://github.com/containerd/containerd/security/advisories/GHSA-5ffw-gxpp-mxpf
MLIST http://www.openwall.com/lists/oss-security/2022/06/07/1
MISC https://github.com/containerd/containerd/commit/c1bcabb4541930f643aa36a2b38655e131346382
DEBIAN https://www.debian.org/security/2022/dsa-5162
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/REOZCUAPCA7NFDWYBDYX6EYXWLHABKBO/
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/WSIGDBHAB3I75JBJNGWEPBTJPS2FOVHD/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:linuxfoundation:containerd:*:*:*:*:*:*:*:* containerd >= None < 1.5.13
cpe:2.3:a:linuxfoundation:containerd:*:*:*:*:*:*:*:* containerd >= 1.6.0 < 1.6.6

Vulnerable and fixed packages

Source package Branch Version Maintainer Status