CVE-2022-31001

Name
CVE-2022-31001
Description
Sofia-SIP is an open-source Session Initiation Protocol (SIP) User-Agent library. Prior to version 1.13.8, an attacker can send a message with evil sdp to FreeSWITCH, which may cause crash. This type of crash may be caused by `#define MATCH(s, m) (strncmp(s, m, n = sizeof(m) - 1) == 0)`, which will make `n` bigger and trigger out-of-bound access when `IS_NON_WS(s[n])`. Version 1.13.8 contains a patch for this issue.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://github.com/freeswitch/sofia-sip/commit/a99804b336d0e16d26ab7119d56184d2d7110a36
CONFIRM https://github.com/freeswitch/sofia-sip/security/advisories/GHSA-79jq-hh82-cv9g
Mailing List https://lists.debian.org/debian-lts-announce/2022/09/msg00001.html
Third Party Advisory https://security.gentoo.org/glsa/202210-18

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:signalwire:sofia-sip:*:*:*:*:*:*:*:* sofia-sip >= None < 1.13.8

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
sofia-sip 3.16-main 1.13.7-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
sofia-sip 3.15-main 1.13.6-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
sofia-sip 3.14-main 1.13.4-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable