CVE-2022-29155

Name
CVE-2022-29155
Description
In OpenLDAP 2.x before 2.5.12 and 2.6.x before 2.6.2, a SQL injection vulnerability exists in the experimental back-sql backend to slapd, via a SQL statement within an LDAP query. This can occur during an LDAP search operation when the search filter is processed, due to a lack of proper escaping.
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://bugs.openldap.org/show_bug.cgi?id=9815

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:openldap:openldap:*:*:*:*:*:*:*:* openldap >= 2.6.0 < 2.6.2
cpe:2.3:a:openldap:openldap:*:*:*:*:*:*:*:* openldap >= 2.0 < 2.5.12

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
openldap 3.15-main 2.6.0-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
openldap 3.14-main 2.4.58-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
openldap 3.13-main 2.4.57-r1 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
openldap 3.12-main 2.4.58-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable