CVE-2022-29043

Name
CVE-2022-29043
Description
Jenkins Mask Passwords Plugin 3.0 and earlier does not escape the name and description of Non-Stored Password parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
CONFIRM https://www.jenkins.io/security/advisory/2022-04-12/#SECURITY-2617

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:mask_passwords:*:*:*:*:*:jenkins:*:* jenkins >= None <= 3.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins 3.15-community 2.319.3-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins edge-community 2.332.3-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable