CVE-2022-28614

Name
CVE-2022-28614
Description
The ap_rwrite() function in Apache HTTP Server 2.4.53 and earlier may read unintended memory if an attacker can cause the server to reflect very large input using ap_rwrite() or ap_rputs(), such as with mod_luas r:puts() function. Modules compiled and distributed separately from Apache HTTP Server that use the 'ap_rputs' function and may pass it a very large (INT_MAX or larger) string must be compiled against current headers to resolve the issue.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MLIST http://www.openwall.com/lists/oss-security/2022/06/08/4
MISC https://httpd.apache.org/security/vulnerabilities_24.html
Third Party Advisory https://security.netapp.com/advisory/ntap-20220624-0005/
Mailing List https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/YPY2BLEVJWFH34AX77ZJPLD2OOBYR6ND/
Mailing List https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/7QUGG2QZWHTITMABFLVXA4DNYUOTPWYQ/
Third Party Advisory https://security.gentoo.org/glsa/202208-20

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:* http_server >= None <= 2.4.53

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
apache2 3.13-main 2.4.54-r0 Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi> fixed