CVE-2022-28202

Name
CVE-2022-28202
Description
An XSS issue was discovered in MediaWiki before 1.35.6, 1.36.x before 1.36.4, and 1.37.x before 1.37.2. The widthheight, widthheightpage, and nbytes properties of messages are not escaped when used in galleries or Special:RevisionDelete.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://phabricator.wikimedia.org/T297543
Mailing List https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/PT4CHJKOQOVMI65TSNZRNV6FIWU7SGZD/
Mailing List https://lists.debian.org/debian-lts-announce/2022/09/msg00027.html
Third Party Advisory https://www.debian.org/security/2022/dsa-5246

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* mediawiki >= None < 1.35.6
cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* mediawiki >= 1.36.0 < 1.36.4
cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* mediawiki >= 1.37.0 < 1.37.2

Vulnerable and fixed packages

Source package Branch Version Maintainer Status