CVE-2022-28134

Name
CVE-2022-28134
Description
Jenkins Bitbucket Server Integration Plugin 3.1.0 and earlier does not perform permission checks in several HTTP endpoints, allowing attackers with Overall/Read permission to create, view, and delete BitBucket Server consumers.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
CONFIRM https://www.jenkins.io/security/advisory/2022-03-29/#SECURITY-2640
MLIST http://www.openwall.com/lists/oss-security/2022/03/29/1

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:bitbucket_server_integration:*:*:*:*:*:jenkins:*:* jenkins >= None <= 3.1.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins 3.15-community 2.319.3-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins edge-community 2.332.3-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.16-community 2.332.3-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable