CVE-2022-27776

Name
CVE-2022-27776
Description
A insufficiently protected credentials vulnerability in fixed in curl 7.83.0 might leak authentication or cookie header data on HTTP redirects to the same host but another port number.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://hackerone.com/reports/1547048
CONFIRM https://security.netapp.com/advisory/ntap-20220609-0008/
Third Party Advisory https://www.debian.org/security/2022/dsa-5197
Mailing List https://lists.debian.org/debian-lts-announce/2022/08/msg00017.html
Mailing List https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/7N5ZBWLNNPZKFK7Q4KEHGCJ2YELQEUJP/
Mailing List https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/DKKOQXPYLMBSEVDHFS32BPBR3ZQJKY5B/
Third Party Advisory https://security.gentoo.org/glsa/202212-01
https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/7N5ZBWLNNPZKFK7Q4KEHGCJ2YELQEUJP/
https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DKKOQXPYLMBSEVDHFS32BPBR3ZQJKY5B/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:haxx:curl:*:*:*:*:*:*:*:* curl >= None < 7.83.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
curl 3.12-main 7.79.1-r1 Natanael Copa <ncopa@alpinelinux.org> fixed