CVE-2022-27775

Name
CVE-2022-27775
Description
An information disclosure vulnerability exists in curl 7.65.0 to 7.82.0 are vulnerable that by using an IPv6 address that was in the connection pool but with a different zone id it could reuse a connection instead.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://hackerone.com/reports/1546268
CONFIRM https://security.netapp.com/advisory/ntap-20220609-0008/
Third Party Advisory https://www.debian.org/security/2022/dsa-5197
Third Party Advisory https://security.gentoo.org/glsa/202212-01

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:haxx:curl:*:*:*:*:*:*:*:* curl >= 7.65.0 <= 7.82.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
curl 3.12-main 7.79.1-r1 Natanael Copa <ncopa@alpinelinux.org> fixed