CVE-2022-27382

Name
CVE-2022-27382
Description
MariaDB Server v10.7 and below was discovered to contain a segmentation fault via the component Item_field::used_tables/update_depend_map_for_order.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://jira.mariadb.org/browse/MDEV-26402

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:* mariadb >= None <= 10.7

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
mariadb edge-main 10.6.7-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
mariadb 3.15-main 10.6.7-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
mariadb 3.14-main 10.5.15-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
mariadb 3.13-main 10.5.15-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
mariadb 3.12-main 10.4.24-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable