CVE-2022-26377

Name
CVE-2022-26377
Description
Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in mod_proxy_ajp of Apache HTTP Server allows an attacker to smuggle requests to the AJP server it forwards requests to. This issue affects Apache HTTP Server Apache HTTP Server 2.4 version 2.4.53 and prior versions.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MLIST http://www.openwall.com/lists/oss-security/2022/06/08/2
MISC https://httpd.apache.org/security/vulnerabilities_24.html
Third Party Advisory https://security.netapp.com/advisory/ntap-20220624-0005/
Mailing List https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/YPY2BLEVJWFH34AX77ZJPLD2OOBYR6ND/
Mailing List https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/7QUGG2QZWHTITMABFLVXA4DNYUOTPWYQ/
Third Party Advisory https://security.gentoo.org/glsa/202208-20

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:* http_server >= 2.4.0 <= 2.4.53

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
apache2 3.13-main 2.4.54-r0 Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi> fixed