CVE-2022-2500

Name
CVE-2022-2500
Description
A cross-site scripting issue has been discovered in GitLab CE/EE affecting all versions before 15.0.5, 15.1 prior to 15.1.4, and 15.2 prior to 15.2.1. A stored XSS flaw in job error messages allows attackers to perform arbitrary actions on behalf of victims at client side.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
CONFIRM https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-2500.json
MISC https://gitlab.com/gitlab-org/gitlab/-/issues/363725
MISC https://hackerone.com/reports/1579645

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* gitlab >= None < 15.0.5
cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* gitlab >= 15.1.0 < 15.1.4
cpe:2.3:a:gitlab:gitlab:15.2:*:*:*:enterprise:*:*:* gitlab == None == 15.2

Vulnerable and fixed packages

Source package Branch Version Maintainer Status