CVE-2022-24786

Name
CVE-2022-24786
Description
PJSIP is a free and open source multimedia communication library written in C. PJSIP versions 2.12 and prior do not parse incoming RTCP feedback RPSI (Reference Picture Selection Indication) packet, but any app that directly uses pjmedia_rtcp_fb_parse_rpsi() will be affected. A patch is available in the `master` branch of the `pjsip/pjproject` GitHub repository. There are currently no known workarounds.
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
CONFIRM https://github.com/pjsip/pjproject/security/advisories/GHSA-vhxv-phmx-g52q
MISC https://github.com/pjsip/pjproject/commit/11559e49e65bdf00922ad5ae28913ec6a198d508
Third Party Advisory https://security.gentoo.org/glsa/202210-37
MLIST https://lists.debian.org/debian-lts-announce/2022/11/msg00021.html
DEBIAN https://www.debian.org/security/2022/dsa-5285

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:pjsip:pjsip:*:*:*:*:*:*:*:* pjsip >= None <= 2.12

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
pjproject 3.16-main 2.12.1-r0 Natanael Copa <ncopa@alpinelinux.org> fixed