CVE-2022-24052

Name
CVE-2022-24052
Description
MariaDB CONNECT Storage Engine Heap-based Buffer Overflow Privilege Escalation Vulnerability. This vulnerability allows local attackers to escalate privileges on affected installations of MariaDB. Authentication is required to exploit this vulnerability. The specific flaw exists within the processing of SQL queries. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a fixed-length heap-based buffer. An attacker can leverage this vulnerability to escalate privileges and execute arbitrary code in the context of the service account. Was ZDI-CAN-16190.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://mariadb.com/kb/en/security/
MISC https://www.zerodayinitiative.com/advisories/ZDI-22-367/
CONFIRM https://security.netapp.com/advisory/ntap-20220318-0004/
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/NJ4KDAGF3H4D4BDTHRAM6ZEAJJWWMRUO/
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/DKJRBYJAQCOPHSED43A3HUPNKQLDTFGD/
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/EZFZVMJL5UDTOZMARLXQIMG3BTG6UNYW/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:* mariadb >= 10.2.0 < 10.2.42
cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:* mariadb >= 10.3.0 < 10.3.33
cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:* mariadb >= 10.4.0 < 10.4.23
cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:* mariadb >= 10.5.0 < 10.5.14
cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:* mariadb >= 10.6.0 < 10.6.6
cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:* mariadb >= 10.7.0 < 10.7.2
cpe:2.3:a:mariadb:mariadb:10.8.0:*:*:*:*:*:*:* mariadb == None == 10.8.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status