CVE-2022-23853

Name
CVE-2022-23853
Description
The LSP (Language Server Protocol) plugin in KDE Kate before 21.12.2 and KTextEditor before 5.91.0 tries to execute the associated LSP server binary when opening a file of a given type. If this binary is absent from the PATH, it will try running the LSP server binary in the directory of the file that was just opened (due to a misunderstanding of the QProcess API, that was never intended). This can be an untrusted directory.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://apps.kde.org/kate/
CONFIRM https://kde.org/info/security/advisory-20220131-1.txt

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:kde:kate:*:*:*:*:*:*:*:* kate >= None < 21.12.2
cpe:2.3:a:kde:ktexteditor:*:*:*:*:*:*:*:* ktexteditor >= None < 5.91.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
kate 3.15-community 21.08.3-r0 Bart Ribbers <bribbers@disroot.org> possibly vulnerable
ktexteditor 3.15-community 5.88.0-r0 Bart Ribbers <bribbers@disroot.org> possibly vulnerable