CVE-2022-23648

Name
CVE-2022-23648
Description
containerd is a container runtime available as a daemon for Linux and Windows. A bug was found in containerd prior to versions 1.6.1, 1.5.10, and 1.14.12 where containers launched through containerd’s CRI implementation on Linux with a specially-crafted image configuration could gain access to read-only copies of arbitrary files and directories on the host. This may bypass any policy-based enforcement on container setup (including a Kubernetes Pod Security Policy) and expose potentially sensitive information. Kubernetes and crictl can both be configured to use containerd’s CRI implementation. This bug has been fixed in containerd 1.6.1, 1.5.10, and 1.4.12. Users should update to these versions to resolve the issue.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Third Party Advisory https://github.com/containerd/containerd/security/advisories/GHSA-crp2-qrr5-8pq7
Patch https://github.com/containerd/containerd/releases/tag/v1.4.13
Patch https://github.com/containerd/containerd/releases/tag/v1.6.1
Patch https://github.com/containerd/containerd/releases/tag/v1.5.10
Patch https://github.com/containerd/containerd/commit/10f428dac7cec44c864e1b830a4623af27a9fc70
DEBIAN https://www.debian.org/security/2022/dsa-5091
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/OCCARJ6FU4MWBTXHZNMS7NELPDBIX2VO/
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/AUDQUQBZJGBWJPMRVB6QCCCRF7O3O4PA/
MISC http://packetstormsecurity.com/files/166421/containerd-Image-Volume-Insecure-Handling.html
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/HFTS2EF3S7HNYSNZSEJZIJHPRU7OPUV3/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:linuxfoundation:containerd:*:*:*:*:*:*:*:* containerd >= None < 1.4.13
cpe:2.3:a:linuxfoundation:containerd:*:*:*:*:*:*:*:* containerd >= 1.5.0 < 1.5.10
cpe:2.3:a:linuxfoundation:containerd:*:*:*:*:*:*:*:* containerd >= 1.6.0 < 1.6.1

Vulnerable and fixed packages

Source package Branch Version Maintainer Status