CVE-2022-23524

Name
CVE-2022-23524
Description
Helm is a tool for managing Charts, pre-configured Kubernetes resources. Versions prior to 3.10.3 are subject to Uncontrolled Resource Consumption, resulting in Denial of Service. Input to functions in the _strvals_ package can cause a stack overflow. In Go, a stack overflow cannot be recovered from. Applications that use functions from the _strvals_ package in the Helm SDK can have a Denial of Service attack when they use this package and it panics. This issue has been patched in 3.10.3. SDK users can validate strings supplied by users won't create large arrays causing significant memory usage before passing them to the _strvals_ functions.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://github.com/helm/helm/security/advisories/GHSA-6rx9-889q-vv2r

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:helm:helm:*:*:*:*:*:*:*:* helm >= 3.0.0 < 3.10.3

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
helm 3.17-community 3.10.2-r1 techknowlogick <techknowlogick@gitea.io> possibly vulnerable