CVE-2022-23107

Name
CVE-2022-23107
Description
Jenkins Warnings Next Generation Plugin 9.10.2 and earlier does not restrict the name of a file when configuring custom ID, allowing attackers with Item/Configure permission to write and read specific files with a hard-coded suffix on the Jenkins controller file system.
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
CONFIRM https://www.jenkins.io/security/advisory/2022-01-12/#SECURITY-2090
MLIST http://www.openwall.com/lists/oss-security/2022/01/12/6

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:warnings_next_generation:*:*:*:*:*:jenkins:*:* jenkins >= None <= 9.10.2
cpe:2.3:a:jenkins:warnings_next_generation:*:*:*:*:*:jenkins:*:* jenkins >= 9.0.0 < 9.0.2
cpe:2.3:a:jenkins:warnings_next_generation:*:*:*:*:*:jenkins:*:* jenkins >= 9.5.0 < 9.5.2
cpe:2.3:a:jenkins:warnings_next_generation:9.7.0:*:*:*:*:jenkins:*:* jenkins == None == 9.7.0
cpe:2.3:a:jenkins:warnings_next_generation:*:*:*:*:*:jenkins:*:* jenkins >= 9.10.0 <= 9.10.2

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins 3.15-community 2.319.3-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable