CVE-2022-2304

Name
CVE-2022-2304
Description
Stack-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://github.com/vim/vim/commit/54e5fed6d27b747ff152cdb6edfb72ff60e70939
CONFIRM https://huntr.dev/bounties/eb7402f3-025a-402f-97a7-c38700d9548a

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:* vim >= None < 9.0.0035

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
vim 3.16-main 8.2.5000-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
vim 3.15-main 8.2.4836-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
vim 3.14-main 8.2.4836-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
vim 3.13-main 8.2.4836-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable