CVE-2022-22818

Name
CVE-2022-22818
Description
The {% debug %} template tag in Django 2.2 before 2.2.27, 3.2 before 3.2.12, and 4.0 before 4.0.2 does not properly encode the current context. This may lead to XSS.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://docs.djangoproject.com/en/4.0/releases/security/
CONFIRM https://www.djangoproject.com/weblog/2022/feb/01/security-releases/
MISC https://groups.google.com/forum/#!forum/django-announce
Mailing List https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/B4SQG2EAF4WCI2SLRL6XRDJ3RPK3ZRDV/
Third Party Advisory https://security.netapp.com/advisory/ntap-20220221-0003/
Third Party Advisory https://www.debian.org/security/2022/dsa-5254
https://groups.google.com/forum/#%21forum/django-announce
https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/B4SQG2EAF4WCI2SLRL6XRDJ3RPK3ZRDV/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* django >= 2.2 < 2.2.27
cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* django >= 3.2 < 3.2.12
cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* django >= 4.0 < 4.0.2

Vulnerable and fixed packages

Source package Branch Version Maintainer Status