CVE-2022-2210

Name
CVE-2022-2210
Description
Out-of-bounds Write in GitHub repository vim/vim prior to 8.2.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
CONFIRM https://huntr.dev/bounties/020845f8-f047-4072-af0f-3726fe1aea25
MISC https://github.com/vim/vim/commit/c101abff4c6756db4f5e740fde289decb9452efa
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/GFD2A4YLBR7OIRHTL7CK6YNMEIQ264CN/
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/U743FMJGFQ35GBPCQ6OWMVZEJPDFVEWM/
Third Party Advisory https://security.gentoo.org/glsa/202208-32

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:* vim >= None < 8.2.5164

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
vim 3.16-main 8.2.5000-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
vim 3.15-main 8.2.4836-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable