CVE-2022-2175

Name
CVE-2022-2175
Description
Buffer Over-read in GitHub repository vim/vim prior to 8.2.
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://github.com/vim/vim/commit/6046aded8da002b08d380db29de2ba0268b6616e
CONFIRM https://huntr.dev/bounties/7f0481c2-8b57-4324-b47c-795d1ea67e55
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/GFD2A4YLBR7OIRHTL7CK6YNMEIQ264CN/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:* vim >= None < 8.2.5148

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
vim 3.16-main 8.2.5000-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
vim 3.15-main 8.2.4836-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
vim 3.14-main 8.2.4836-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
vim 3.13-main 8.2.4836-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable