CVE-2022-20001

Name
CVE-2022-20001
Description
fish is a command line shell. fish version 3.1.0 through version 3.3.1 is vulnerable to arbitrary code execution. git repositories can contain per-repository configuration that change the behavior of git, including running arbitrary commands. When using the default configuration of fish, changing to a directory automatically runs `git` commands in order to display information about the current repository in the prompt. If an attacker can convince a user to change their current directory into one controlled by the attacker, such as on a shared file system or extracted archive, fish will run arbitrary commands under the attacker's control. This problem has been fixed in fish 3.4.0. Note that running git in these directories, including using the git tab completion, remains a potential trigger for this issue. As a workaround, remove the `fish_git_prompt` function from the prompt.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://github.com/fish-shell/fish-shell/pull/8589
CONFIRM https://github.com/fish-shell/fish-shell/security/advisories/GHSA-pj5f-6vxj-f5mq
MISC https://github.com/fish-shell/fish-shell/releases/tag/3.4.0
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/TRNMYS2LKB6TKOOBQQRSRQICDMWLZ4QL/
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/BPZ7JV22DSZB5LNUCUEJ2HO3PKM2TVVK/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:fishshell:fish:*:*:*:*:*:*:*:* fish >= 3.1.0 <= 3.3.1

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
fish 3.15-main 3.3.1-r1 Bart Ribbers <bribbers@disroot.org> possibly vulnerable
fish 3.14-main 3.2.2-r1 Leo <thinkabit.ukim@gmail.com> possibly vulnerable
fish 3.13-main 3.1.2-r4 Leo <thinkabit.ukim@gmail.com> possibly vulnerable
fish 3.12-main 3.1.2-r0 Leo <thinkabit.ukim@gmail.com> possibly vulnerable