CVE-2022-1428

Name
CVE-2022-1428
Description
An issue has been discovered in GitLab affecting all versions before 14.8.6, all versions starting from 14.9 before 14.9.4, all versions starting from 14.10 before 14.10.1. GitLab was incorrectly verifying throttling limits for authenticated package requests which resulted in limits not being enforced.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
CONFIRM https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-1428.json
MISC https://gitlab.com/gitlab-org/gitlab/-/issues/342481

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:gitlab:gitlab:14.10.0:*:*:*:enterprise:*:*:* gitlab == None == 14.10.0
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* gitlab >= 14.9.0 < 14.9.4
cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* gitlab >= None < 14.8.6

Vulnerable and fixed packages

Source package Branch Version Maintainer Status