CVE-2022-1115

Name
CVE-2022-1115
Description
A heap-buffer-overflow flaw was found in ImageMagick’s PushShortPixel() function of quantum-private.h file. This vulnerability is triggered when an attacker passes a specially crafted TIFF image file to ImageMagick for conversion, potentially leading to a denial of service.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://github.com/ImageMagick/ImageMagick/issues/4974
MISC https://access.redhat.com/security/cve/CVE-2022-1115
MISC https://github.com/ImageMagick/ImageMagick/commit/c8718305f120293d8bf13724f12eed885d830b09
MISC https://github.com/ImageMagick/ImageMagick6/commit/1f860f52bd8d58737ad883072203391096b30b51
MISC https://bugzilla.redhat.com/show_bug.cgi?id=2067022

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:imagemagick:imagemagick:*:*:*:*:*:*:*:* imagemagick >= None < 6.9.12-44
cpe:2.3:a:imagemagick:imagemagick:*:*:*:*:*:*:*:* imagemagick >= 7.0.0-0 < 7.1.0-29

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
imagemagick 3.16-community 7.1.0.35-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
imagemagick edge-community 7.1.0.49-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable