CVE-2022-1114

Name
CVE-2022-1114
Description
A heap-use-after-free flaw was found in ImageMagick's RelinquishDCMInfo() function of dcm.c file. This vulnerability is triggered when an attacker passes a specially crafted DICOM image file to ImageMagick for conversion, potentially leading to information disclosure and a denial of service.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://bugzilla.redhat.com/show_bug.cgi?id=2064538

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:imagemagick:imagemagick:*:*:*:*:*:*:*:* imagemagick >= 7.0.0-0 < 7.1.0-28
cpe:2.3:a:imagemagick:imagemagick:*:*:*:*:*:*:*:* imagemagick >= 6.0 < 6.9.12-43

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
imagemagick 3.15-community 7.1.0.16-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
imagemagick 3.16-community 7.1.0.35-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
imagemagick edge-community 7.1.0.39-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable