CVE-2022-0367

Name
CVE-2022-0367
Description
A heap-based buffer overflow flaw was found in libmodbus in function modbus_reply() in src/modbus.c.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://github.com/stephane/libmodbus/issues/614
MISC https://bugzilla.redhat.com/show_bug.cgi?id=2045571
MISC https://github.com/stephane/libmodbus/commit/b4ef4c17d618eba0adccc4c7d9e9a1ef809fc9b6
MLIST https://lists.debian.org/debian-lts-announce/2022/09/msg00007.html

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:libmodbus:libmodbus:*:*:*:*:*:*:*:* libmodbus >= None < 3.1.7

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
libmodbus edge-community 3.1.6-r1 Oz Tiram <oz.tiram@gmail.com> possibly vulnerable
libmodbus 3.16-community 3.1.6-r1 Oz Tiram <oz.tiram@gmail.com> possibly vulnerable