CVE-2022-0284

Name
CVE-2022-0284
Description
A heap-based-buffer-over-read flaw was found in ImageMagick's GetPixelAlpha() function of 'pixel-accessor.h'. This vulnerability is triggered when an attacker passes a specially crafted Tagged Image File Format (TIFF) image to convert it into a PICON file format. This issue can potentially lead to a denial of service and information disclosure.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://bugzilla.redhat.com/show_bug.cgi?id=2045943
MISC https://github.com/ImageMagick/ImageMagick/issues/4729
MISC https://access.redhat.com/security/cve/CVE-2022-0284
MISC https://github.com/ImageMagick/ImageMagick/commit/e50f19fd73c792ebe912df8ab83aa51a243a3da7

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:imagemagick:imagemagick:*:*:*:*:*:*:*:* imagemagick >= None < 7.1.0-20

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
imagemagick 3.16-community 7.1.0.35-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
imagemagick edge-community 7.1.0.49-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable