CVE-2022-0128

Name
CVE-2022-0128
Description
vim is vulnerable to Out-of-bounds Read
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://github.com/vim/vim/commit/d3a117814d6acbf0dca3eff1a7626843b9b3734a
CONFIRM https://huntr.dev/bounties/63f51299-008a-4112-b85b-1e904aadd4ba
MLIST http://www.openwall.com/lists/oss-security/2022/01/15/1

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:* vim >= None < 8.2.4009

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
vim edge-main 8.2.4173-r0 Natanael Copa <ncopa@alpinelinux.org> fixed
vim 3.15-main 8.2.4173-r0 Natanael Copa <ncopa@alpinelinux.org> fixed
vim 3.14-main 8.2.4173-r0 Natanael Copa <ncopa@alpinelinux.org> fixed
vim 3.13-main 8.2.4173-r0 Natanael Copa <ncopa@alpinelinux.org> fixed
vim 3.12-main 8.2.4173-r0 Natanael Copa <ncopa@alpinelinux.org> fixed