CVE-2021-46662

Name
CVE-2021-46662
Description
MariaDB through 10.5.9 allows a set_var.cc application crash via certain uses of an UPDATE statement in conjunction with a nested subquery.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://jira.mariadb.org/browse/MDEV-25637
Third Party Advisory https://security.netapp.com/advisory/ntap-20220221-0002/
Patch https://mariadb.com/kb/en/security/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:* mariadb >= None <= 10.5.9
cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:* mariadb >= 10.3.0 < 10.3.32
cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:* mariadb >= 10.4.0 < 10.4.22
cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:* mariadb >= 10.5.0 < 10.5.13
cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:* mariadb >= 10.6.0 < 10.6.5

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
mariadb edge-main 10.6.7-r0 Natanael Copa <ncopa@alpinelinux.org> fixed
mariadb 3.15-main 10.6.7-r0 Natanael Copa <ncopa@alpinelinux.org> fixed
mariadb 3.12-main 10.4.24-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable