CVE-2021-46142

Name
CVE-2021-46142
Description
An issue was discovered in uriparser before 0.9.6. It performs invalid free operations in uriNormalizeSyntax.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://github.com/uriparser/uriparser/issues/122
MISC https://github.com/uriparser/uriparser/pull/124
CONFIRM https://blog.hartwork.org/posts/uriparser-096-with-security-fixes-released/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:uriparser_project:uriparser:*:*:*:*:*:*:*:* uriparser >= None < 0.9.6

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
uriparser edge-community 0.9.6-r0 Fabian Affolter <fabian@affolter-engineering.ch> fixed
uriparser 3.15-community 0.9.6-r0 Fabian Affolter <fabian@affolter-engineering.ch> fixed
uriparser 3.12-main 0.9.3-r1 Fabian Affolter <fabian@affolter-engineering.ch> possibly vulnerable