CVE-2021-44141

Name
CVE-2021-44141
Description
All versions of Samba prior to 4.15.5 are vulnerable to a malicious client using a server symlink to determine if a file or directory exists in an area of the server file system not exported under the share definition. SMB1 with unix extensions has to be enabled in order for this attack to succeed.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Mitigation https://www.samba.org/samba/security/CVE-2021-44141.html

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:samba:samba:*:*:*:*:*:*:*:* samba >= None < 4.15.5

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
samba 3.15-main 4.15.5-r0 Natanael Copa <ncopa@alpinelinux.org> fixed
samba 3.14-main 4.14.12-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
samba 3.13-main 4.13.17-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
samba 3.12-main 4.12.15-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable