CVE-2021-43809

Name
CVE-2021-43809
Description
`Bundler` is a package for managing application dependencies in Ruby. In `bundler` versions before 2.2.33, when working with untrusted and apparently harmless `Gemfile`'s, it is not expected that they lead to execution of external code, unless that's explicit in the ruby code inside the `Gemfile` itself. However, if the `Gemfile` includes `gem` entries that use the `git` option with invalid, but seemingly harmless, values with a leading dash, this can be false. To handle dependencies that come from a Git repository instead of a registry, Bundler uses various commands, such as `git clone`. These commands are being constructed using user input (e.g. the repository URL). When building the commands, Bundler versions before 2.2.33 correctly avoid Command Injection vulnerabilities by passing an array of arguments instead of a command string. However, there is the possibility that a user input starts with a dash (`-`) and is therefore treated as an optional argument instead of a positional one. This can lead to Code Execution because some of the commands have options that can be leveraged to run arbitrary executables. Since this value comes from the `Gemfile` file, it can contain any character, including a leading dash. To exploit this vulnerability, an attacker has to craft a directory containing a `Gemfile` file that declares a dependency that is located in a Git repository. This dependency has to have a Git URL in the form of `-u./payload`. This URL will be used to construct a Git clone command but will be interpreted as the upload-pack argument. Then this directory needs to be shared with the victim, who then needs to run a command that evaluates the Gemfile, such as `bundle lock`, inside. This vulnerability can lead to Arbitrary Code Execution, which could potentially lead to the takeover of the system. However, the exploitability is very low, because it requires a lot of user interaction. Bundler 2.2.33 has patched this problem by inserting `--` as an argument before any positional arguments to those Git commands that were affected by this issue. Regardless of whether users can upgrade or not, they should review any untrustred `Gemfile`'s before running any `bundler` commands that may read them, since they can contain arbitrary ruby code.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://github.com/rubygems/rubygems/commit/a4f2f8ac17e6ce81c689527a8b6f14381060d95f
CONFIRM https://github.com/rubygems/rubygems/security/advisories/GHSA-fj7f-vq84-fh43
MISC https://github.com/rubygems/rubygems/pull/5142
MISC https://github.com/rubygems/rubygems/commit/0fad1ccfe9dd7a3c5b82c1496df3c2b4842870d3

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:bundler:bundler:*:*:*:*:*:ruby:*:* ruby-bundler >= None < 2.2.33

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
ruby-bundler 3.15-main 2.2.31-r0 Jakub Jirutka <jakub@jirutka.cz> possibly vulnerable
ruby-bundler 3.14-main 2.2.20-r0 Jakub Jirutka <jakub@jirutka.cz> possibly vulnerable
ruby-bundler 3.13-main 2.2.2-r0 Jakub Jirutka <jakub@jirutka.cz> possibly vulnerable
ruby-bundler 3.12-main 2.1.4-r1 Jakub Jirutka <jakub@jirutka.cz> possibly vulnerable