CVE-2021-43577

Name
CVE-2021-43577
Description
Jenkins OWASP Dependency-Check Plugin 5.1.1 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
CONFIRM https://www.jenkins.io/security/advisory/2021-11-12/#SECURITY-2488
MLIST http://www.openwall.com/lists/oss-security/2021/11/12/1

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:owasp_dependency-check:*:*:*:*:*:jenkins:*:* jenkins >= None <= 5.1.1

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins edge-community 2.307-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.14-community 2.297-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable