CVE-2021-4217

Name
CVE-2021-4217
Description
A flaw was found in unzip. The vulnerability occurs due to improper handling of Unicode strings, which can lead to a null pointer dereference. This flaw allows an attacker to input a specially crafted zip file, leading to a crash or code execution.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://bugs.launchpad.net/ubuntu/+source/unzip/+bug/1957077
MISC https://bugzilla.redhat.com/show_bug.cgi?id=2044583
MISC https://access.redhat.com/security/cve/CVE-2021-4217

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:unzip_project:unzip:6.0:*:*:*:*:*:*:* unzip == None == 6.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
unzip edge-main 6.0-r10 Timo Teräs <timo.teras@iki.fi> possibly vulnerable
unzip 3.16-main 6.0-r9 Timo Teräs <timo.teras@iki.fi> possibly vulnerable
unzip 3.15-main 6.0-r9 Timo Teräs <timo.teras@iki.fi> possibly vulnerable
unzip 3.14-main 6.0-r9 Timo Teräs <timo.teras@iki.fi> possibly vulnerable
unzip 3.13-main 6.0-r9 Timo Teräs <timo.teras@iki.fi> possibly vulnerable