CVE-2021-41213

Name
CVE-2021-41213
Description
TensorFlow is an open source platform for machine learning. In affected versions the code behind `tf.function` API can be made to deadlock when two `tf.function` decorated Python functions are mutually recursive. This occurs due to using a non-reentrant `Lock` Python object. Loading any model which contains mutually recursive functions is vulnerable. An attacker can cause denial of service by causing users to load such models and calling a recursive `tf.function`, although this is not a frequent scenario. The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://github.com/tensorflow/tensorflow/commit/afac8158d43691661ad083f6dd9e56f327c1dcb7
CONFIRM https://github.com/tensorflow/tensorflow/security/advisories/GHSA-h67m-xg8f-fxcf

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* tensorflow >= 2.4.0 < 2.4.4
cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* tensorflow >= 2.5.0 < 2.5.2
cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* tensorflow >= 2.6.0 < 2.6.1
cpe:2.3:a:google:tensorflow:2.7.0:rc0:*:*:*:*:*:* tensorflow == None == 2.7.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status