CVE-2021-40393

Name
CVE-2021-40393
Description
An out-of-bounds write vulnerability exists in the RS-274X aperture macro variables handling functionality of Gerbv 2.7.0 and dev (commit b5f1eacd) and the forked version of Gerbv (commit 71493260). A specially-crafted gerber file can lead to code execution. An attacker can provide a malicious file to trigger this vulnerability.
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://talosintelligence.com/vulnerability_reports/TALOS-2021-1404

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:gerbv_project:gerbv:2.7.0:*:*:*:*:*:*:* gerbv == None == 2.7.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status