CVE-2021-39935

Name
CVE-2021-39935
Description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 10.5 before 14.3.6, all versions starting from 14.4 before 14.4.4, all versions starting from 14.5 before 14.5.2. Unauthorized external users could perform Server Side Requests via the CI Lint API
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://hackerone.com/reports/1236965
CONFIRM https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39935.json
MISC https://gitlab.com/gitlab-org/gitlab/-/issues/346187

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* gitlab >= 10.5.0 < 14.3.6
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* gitlab >= 14.4.0 < 14.4.4
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* gitlab >= 14.5.0 < 14.5.2

Vulnerable and fixed packages

Source package Branch Version Maintainer Status