CVE-2021-39910

Name
CVE-2021-39910
Description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 12.6 before 14.3.6, all versions starting from 14.4 before 14.4.4, all versions starting from 14.5 before 14.5.2. GitLab was vulnerable to HTML Injection through the Swagger UI feature.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
CONFIRM https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39910.json
MISC https://gitlab.com/gitlab-org/gitlab/-/issues/325901
MISC https://hackerone.com/reports/1133656

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* gitlab >= 12.6.0 < 14.3.6
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* gitlab >= 14.4.0 < 14.4.4
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* gitlab >= 14.5.0 < 14.5.2

Vulnerable and fixed packages

Source package Branch Version Maintainer Status