CVE-2021-39874

Name
CVE-2021-39874
Description
In all versions of GitLab CE/EE since version 11.0, the requirement to enforce 2FA is not honored when using git commands.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://gitlab.com/gitlab-org/gitlab/-/issues/222527
MISC https://hackerone.com/reports/898477
CONFIRM https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39874.json

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* gitlab >= 11.0.0 < 14.1.7
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* gitlab >= 14.2 < 14.2.5
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* gitlab >= 14.3 < 14.3.1

Vulnerable and fixed packages

Source package Branch Version Maintainer Status