CVE-2021-3928

Name
CVE-2021-3928
Description
vim is vulnerable to Stack-based Buffer Overflow
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
CONFIRM https://huntr.dev/bounties/29c3ebd2-d601-481c-bf96-76975369d0cd
MISC https://github.com/vim/vim/commit/15d9890eee53afc61eb0a03b878a19cb5672f732
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/PGW56Z6IN4UVM3E5RXXF4G7LGGTRBI5C/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:* vim >= None < 8.2.3582

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
vim 3.14-main 8.2.3437-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
vim 3.13-main 8.2.3437-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
vim 3.12-main 8.2.3437-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
vim 3.11-main 8.2.3437-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable